Задать вопрос
29 ноября, 17:45

Напишите программу (в паскале авс), которая находит НОК (наименьшее общее кратное) двух чисел, введённых с клавиатуры.

+2
Ответы (1)
  1. 29 ноября, 17:53
    0
    Для решения этой задачи воспользуемся формулой:

    а*б=НОД (а, б) * НОК (а, б)

    var a, b:longint;

    function nod (a, b:longint) : longint;

    begin

    if a = 0 then

    nod:=b else

    if b=0 then

    nod:=a else

    if a>b then

    nod:=nod (a mod b, b) else

    nod:=nod (a, b mod a) ;

    end;

    Begin

    read (a, b) ;

    writeln ((a*b) div nod (a, b)) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу (в паскале авс), которая находит НОК (наименьшее общее кратное) двух чисел, введённых с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)
Составьте программу, которая: а) Определяет коды двух введённых с клавиатуры символов; б) Выполняет операцию сцепления трёх введённых с клавиатуры символов; на Pascal
Ответы (1)