Задать вопрос
2 сентября, 19:43

Начав тренировки, лыжник в первый день пробегал 10 км.

В каждый следующий день он увеличивал длину пробега на 10% от предыдущего дня. Определить, в какой день он пробежит 20 км.

Составить программу в паскале.

(Оператор Цикл. Цикл с предусловием.)

+2
Ответы (1)
  1. 2 сентября, 22:35
    0
    Вариант номер 1:

    program c1ba;

    var a:byte;

    p:real;

    begin

    p:=10;

    a:=1;

    repeat begin

    p:=p + (p/10) ;

    a:=a+1;

    end;

    until p>=20;

    writeln ('a=', a) ;

    end.

    Вариант номер 2:

    program c1ba;

    var a:byte;

    p:real;

    begin

    p:=10;

    a:=1;

    while p<=20 do begin

    p:=p + (p/10) ;

    a:=a+1;

    end;

    writeln ('a=', a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Начав тренировки, лыжник в первый день пробегал 10 км. В каждый следующий день он увеличивал длину пробега на 10% от предыдущего дня. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего Определить: а) В какой день он пробежит больше 20 км б) В какой день суммарный
Ответы (1)
Начав тренировки, спортсмен пробежал в первый день 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Сколько он пробегал за каждый день тренировки? Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)
Помогите написать на паскале Начав тренировки лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить пробег лыжника за второй, третий, ..., десятый день.
Ответы (1)
Написать программу на Паскале. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего.
Ответы (1)
Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок. Написать программу в Pascal
Ответы (1)