Задать вопрос
20 мая, 14:54

Написать программу, которая проверяет - имеется ли в записи натурального числа ноль.

Язык программирования паскаль.

+2
Ответы (1)
  1. 20 мая, 18:53
    0
    Program red;

    var a, b, c:integer;

    begin

    b:=0;

    readln (a) ;

    if a<10 then

    begin

    if a*5=0 then b:=1;

    end;

    if (a>=10) and (a<100) then

    begin

    if ((a div 10) * 5=0) then b:=1;

    if ((a mod 10) * 5=0) then b:=1;

    end;

    if (a>=100) and (a<1000) then

    begin

    if ((a div 100) * 5=0) then b:=1;

    if (((a div 10) mod 10) * 5=0) then b:=1;

    if ((a mod 10) * 5=0) then b:=1;

    end;

    if b=1 then writeln ('yes') else writeln ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая проверяет - имеется ли в записи натурального числа ноль. Язык программирования паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
6) Ребята в классе из 30 человек изучают языки программирования, и каждый знает зотя бы один язык. Паскаль изучили 20 человек, Python 15 человек, C + + 10 человек. Паскаль и Python знают 5 человек, Паскаль и C + + 8 человек, Python и С + + 5 человек.
Ответы (1)
1. Написать программу на языке программирования Паскаль, для вычисления значения выражения y=5x+6, если х любые числа и вводится с клавиатуры. 2.
Ответы (1)
Написать программу в паскале, которая проверяет проверяет по заданным трем сторонам треугольник на равносторонность
Ответы (1)