Задать вопрос
7 октября, 12:16

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу, которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих, сумма цифр каждого из которых делится на?"

Входные данные. Два числа

Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

+3
Ответы (1)
  1. 7 октября, 14:53
    0
    Var k, j, sum:integer;

    n, i:longint;

    prev, cur, found : boolean;

    s:string;

    Begin

    read (n, k) ;

    for i : = 2 to n do begin

    s : = inttostr (i) ;

    sum : = 0;

    for j : = 1 to length (s) do

    sum : = sum + strtoint (s[j]) ;

    cur : = (sum mod k) = 0;

    found : = found or (prev and cur) ;

    if prev and cur then

    writeln (i - 1,' ', i) ;

    prev : = cur;

    end;

    if not found then writeln ('NO') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не
Ответы (1)
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)
1 вариант. 1. Найти сумму и произведение первых 6 последовательных натуральных чисел. 2. Найти сумму первых k последовательных нечетных чисел. 3. Вывести на экран натуральные нечётные числа от 5 до 55. 4.
Ответы (1)
Задача 4. Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
Что общего и в чём различие понятий "математическая модель" и "компьютерная математическая модель"?
Ответы (1)