Задать вопрос
11 декабря, 21:16

Дан массив из 10 элементов, заполненный случайным образом. Значения элементов от - 50 до 50. Вывести на экран элементы массива, оканчивающиеся на 4 или 8.

+5
Ответы (1)
  1. 11 декабря, 22:38
    0
    Var

    a: array [1 ... 10] of integer;

    i, n: byte;

    begin

    Randomize;

    for i:=1 to 10 do

    begin

    a[i]:=random (100) - 50;

    n:=abs (a[i] mod 10) ;

    if (n = 4) or (n = 8) then write (a[i]:4) ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 элементов, заполненный случайным образом. Значения элементов от - 50 до 50. Вывести на экран элементы массива, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)