Задать вопрос
7 декабря, 09:40

Составить программу и блок схему вывода всех чисел от 1000 до 9999, в которых 1 цифра равна 4 и 2 цифра равна 3.

+5
Ответы (1)
  1. 7 декабря, 11:01
    0
    Почему-то мой ответ удалили. Напишу подробнее.

    Если в чмсле первая цифра 4 и вторая цифра 3, то числа от 4300 до 4399

    На паскле программа выглядит так

    var i, n: integer

    begin

    uses crt;

    for i: = 0 to 99

    begin

    n = 4300 + i;

    write (n) ;

    end;

    writeln;

    end.

    Блок-схема совсем простая, нарисуй сама.

    1) Начало (в овале)

    2) i = 0 (в прямоугольнике)

    3) n = 4300 + i (в прямоугольнике)

    4) Вывод n (в параллелограмме)

    5) Проверка i > 99? (в ромбе). Если нет, возврат на п. 3. Если да, вниз.

    6) Вывод пустой строки (в параллелограмме)

    7) Конец (в овале)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу и блок схему вывода всех чисел от 1000 до 9999, в которых 1 цифра равна 4 и 2 цифра равна 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы