Задать вопрос
6 марта, 02:51

Одномерный

массив

1. Составьте программу ввода и вывода массива: 5, - 2, 3, - 6, 7, 9, - 4, 8, 1, 2,

7, - 3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A (10)

количества положительных элементов.

3. Составьте программу заполнения и вывода массива, не используя клавиатуру,

числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

+4
Ответы (1)
  1. 6 марта, 06:11
    0
    3)

    const n=10;

    var a:array [1 ... n] of integer; r, i:integer;

    begin

    r:=1;

    for i:=1 to n do begin

    a[i]:=r; inc (r, 2) ; end;

    for i:=1 to n do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Одномерный массив 1. Составьте программу ввода и вывода массива: 5, - 2, 3, - 6, 7, 9, - 4, 8, 1, 2, 7, - 3. 2. Составьте блок-схему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Составьте программу ввода и вывода массива: 5, - 2, 3, - 6, 7, 9, - 4, 8, 1, 2, 7, - 3. 2. Составьте программу заполнения массива A (20) датчиком случайных чисел в диапазоне от - 50 до 49 включительно. 3*.
Ответы (1)