Задать вопрос
15 сентября, 17:59

Каждый ежедневно болеющий гриппом человек может заразить окружающих. Составьте программу, определяющую, через сколько дней заболеют все ученики школы. Число учащихся школы ввести с клавиатуры.

+5
Ответы (1)
  1. 15 сентября, 18:44
    0
    При условии что каждый больной заражает от 1 до 5 человек каждый день, и что больные упорно ходят в школу

    const

    min_posible = 1;

    max_posible = 5;

    var all_students, ill, new_ill, days, i: integer;

    Begin

    Randomize;

    Writeln ('Кол-во учеников школы = >') ;

    read (all_students) ;

    ill : = 1;

    repeat

    days : = days + 1;

    new_ill : = 0;

    for i : = 1 to ill do

    new_ill : = new_ill + Random (min_posible, max_posible) ;

    ill : = ill + new_ill;

    Writeln ('День ', days:3,': Заразилось ', new_ill:5,' Больных ', ill:5) ;

    until ill > = all_students;

    Writeln (days) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Каждый ежедневно болеющий гриппом человек может заразить окружающих. Составьте программу, определяющую, через сколько дней заболеют все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Конспект в тетради. Выберите программу из перечня предложенных с разным уровнем сложности и составьте программу в тетради. 1. Составьте программу, определяющую минимальное число из двух чисел, введенных с клавиатуры. (Уровень А) 2.
Ответы (1)
Из 500 учащихся школы на данный момент болеют гриппом M человек. Определить, через сколько дней будет болеть более половины учеников школы, если каждый день число больных увеличивается на 15% от заболевших.
Ответы (1)