Задать вопрос
4 марта, 10:19

Даны две веревки А и В, А длинная В короткая нужно вычислить сколько раз В входит в А и остаток Х который не вошел? решить не используя деления и умножения. составить программу по Паскалю

+5
Ответы (1)
  1. 4 марта, 11:41
    0
    Uses crt;

    var a, b, ans, x:real;

    begin

    writeln ('Введите длины веревок A B:') ;

    read (a, b) ;

    while a>=b do

    begin

    a:=a-b;

    ans:=ans+1;

    end;

    x:=a;

    writeln ('Ответ: ', ans) ;

    writeln ('Остаток: ', x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны две веревки А и В, А длинная В короткая нужно вычислить сколько раз В входит в А и остаток Х который не вошел? решить не используя ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Помогите решить задачи по паскалю 1. Вычислить z (x) = sign (x) + sign (y) * sign (x+y) Используя функцию sign (x) = - 1 если x0 2. Написать процедуру для нахождения степени числа и вычислить значение выражения:x^5+x^4+x^8 3.
Ответы (1)
Надо составить программу по паскалю) составить программу проверяющую утверждения, что сумма цифр введенного вами числа делится на 5.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)