Задать вопрос
1 августа, 02:45

Написать программу на языке Pascal: Задача: Вводятся целые числа до первого числа, которое меньше двух. Определить, сколько простых чисел было введено. Описание переменных: q - счетчик простых чисел; n - очередное введенное число. Алгоритм решения задачи: Пока введенное число больше 1, проверять его на простоту по следующему алгоритму: Если число делится на любой делитель от 2 до половины от себя, то оно не простое. Если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.

+1
Ответы (1)
  1. 1 августа, 06:31
    0
    Var q, n, i, k, h:integer;

    begin

    readln (n) ;

    h:=1;

    while n>1 do

    begin

    k:=n div 2;

    for i:=2 to k do

    if n mod i=0 then h:=0;

    q:=q+h;

    h:=1;

    readln (n) ;

    end;

    writeln ('Простых чисел: ', q)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке Pascal: Задача: Вводятся целые числа до первого числа, которое меньше двух. Определить, сколько простых чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выполните по словесному описанию алгоритм с ветвлением и запишите ответ: 1. Берем число 24 2. Увеличиваем число в 3 раза 3. Если полученное число меньше чем 103, то увеличиваем его на 5, иначе уменьшаем его на 7 4. Записываем правильный ответ
Ответы (1)
Выполнить по словесному описанию алгоритм: 1. берем число 17 2. повторяем 3 раза делать 3. увеличиваем полученное число в два раза 4. увеличиваем полученное число на 31 конец цикла 5. записываем ответ Помогите решить (в ответе 353)
Ответы (1)
Разработайте алгоритм решения Разработайте алгоритм решения задачи, запишите его в виде блок-схемы. По полученному алгоритму запишите программу на языке Паскаль. Найдите расстояние между двумя точками с заданными координатами.
Ответы (1)
Задача 1. Введено число. Известно, что оно может быть равно от 10 до 999, определить сумму цифр в этом числе Задача 2. Введено три числа. Определить количество четных из них, больших пяти Задача 3.
Ответы (1)
Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде блок-схемы или на языке программирования Pascal) 1. С клавиатуры вводятся три целых числа.
Ответы (2)