Задать вопрос
1 февраля, 10:53

Изменение

элементов массива

Дан массив из N положительных элементов, больших 1

(2<=N<=100).

После каждого элемента вставить его минимальный делитель

больший 1.

Формат входных данных:

На входе подаются в первой строке N - число элементов массива

Вторая строка содержит N чисел - значения элементов массива

Формат выходных данных: Выведите результирующий массив в строку

Пример:

Ввод

5

43 50 76 84 100

Вывод

43 43 50 2 76 2 84 2 100 2

+1
Ответы (1)
  1. 1 февраля, 13:23
    0
    Program gt;

    label 1,2;

    var a, b:array[1 ... 1000]of integer;

    n, i, l, j:integer;

    begin

    read (n) ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    l:=round (sqrt (a[i])) ;

    for j:=2 to l do

    begin

    if (a[i] mod j=0) then goto 1;

    end;

    b[i]:=a[i];

    goto 2;

    1:

    b[i]:=j;

    2:

    end;

    for i:=1 to n do

    begin

    write (a[i],' ', b[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Изменение элементов массива Дан массив из N положительных элементов, больших 1 (2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)