Задать вопрос
10 мая, 09:53

Определить разрядность и знак числа из интервала [-100; 100] число задать случайным образом. Pascal ABC

+3
Ответы (2)
  1. 10 мая, 13:33
    0
    Var

    n:integer;

    b, c:string;

    begin

    n:=random (200) - 100;

    if n>0 then

    b:='+' else b:='-';

    if (abs (n) >10) then

    c:='десятки';

    if (abs (n) <10) then

    c:='единицы';

    writeln ('число=', n,' знак ', b,'разрадность ', c) ;

    end.
  2. 10 мая, 13:43
    0
    Var x:byte;

    razryad, chastnoe:integer;

    begin

    x : = Random (200) - 100;

    razryad : = 0;

    repeat

    razryad : = razryad + 1;

    chastnoe : = x div 10;

    until (chastnoe 0) ;

    if x < 0 then write ("Число: ", x, "отрицательное, количество разрядов: ", razryad) else

    if x > 0 then write ("Число: ", x, "положительное, количество разрядов: ", razryad) else

    write ("Число:", x," равно нулю, количество разрядов: ", razryad) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить разрядность и знак числа из интервала [-100; 100] число задать случайным образом. Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)