Задать вопрос
16 декабря, 05:35

Массив содержит значения температуры, измеренной в 10 точках радиатора охлаждения (°C) : 45, 34, 39, 67, 62, 41, 52, 57, 51, 36. Определить среднюю температуру ''горячих'' (>50 °C) участков радиатора.

+3
Ответы (1)
  1. 16 декабря, 06:33
    0
    Uses crt;

    const

    a:array[1 ... 10] of integer = (45, 34, 39, 67, 62, 41, 52, 57, 51, 36) ;

    var sr:real;

    i, n, sum:integer;

    begin

    for i:=1 to 10 do write (a[i]:3) ;

    writeln;

    for i:=1 to 10 do

    if a[i]>50 then

    begin

    sum:=sum+a[i];

    n:=n+1;

    end;

    sr:=sum/n;

    writeln ('Среднее значение горячих участков: ', sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Массив содержит значения температуры, измеренной в 10 точках радиатора охлаждения (°C) : 45, 34, 39, 67, 62, 41, 52, 57, 51, 36. Определить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
В массивах U7 D7 V7 содержатся значения В массивах U7 D7 V7 содержатся значения утренней дневной и вечерний температуры соответственно, за каждый день недели, сформировать массив S7 в котором будут содержаться значения средне-дневной температуры,
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)