Задать вопрос
30 января, 07:35

Помогите решить задачу на паскале:

в двумерном массиве хранятся результаты (время в минутах), показанные каждым из 12 автогонщиков на каждом из 10 этапов соревнований "Формула-1". После 10 этапа участник с порядковым номером 4 выбыл из соревнований. Изменить массив так, чтобы в нем не было результатов бывшего гонщика.

+5
Ответы (1)
  1. 30 января, 08:26
    0
    Var

    i, j:integer;

    a:array[1 ... 12,1 ... 10]of integer;

    begin

    writeln ('Исходная таблица: ') ;

    for i:=1 to 12 do

    begin

    for j:=1 to 10 do

    begin

    a[i, j]:=50+random (10) ;

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    writeln;

    for i:=5 to 12 do

    for j:=1 to 10 do

    a[i-1, j]:=a[i, j];

    for j:=1 to 10 do a[12, j]:=0;

    writeln ('Измененная таблица: ') ;

    for i:=1 to 11 do

    begin

    for j:=1 to 10 do

    write (a[i, j]:3) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу на паскале: в двумерном массиве хранятся результаты (время в минутах), показанные каждым из 12 автогонщиков на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
результаты соревнований по плаванию для N спортсменов хранятся в массиве K. Выбрать и напечатать лучший из них. Массив заполнить с клавиатуры.
Ответы (1)