Задать вопрос
12 февраля, 06:07

Задача AДоска

Задается N. Нужно вывести цвет каждой клетки доски N x N, если известно, что они покрашены в шахматном порядке и клетка (1, 1) - белая.

Формат входных данных

Первая строка входного файла содержит единственное целое N (1 < = N < = 10).

Формат выходных данных

Выведите N строк в каждой N символов соответствующий цвету этой ячейки: 'W' - если белая и 'B' - если черная.

+2
Ответы (1)
  1. 12 февраля, 07:20
    0
    Var

    n, i, j: integer;

    begin

    readln (n) ;

    for i : = 1 to n do

    begin

    for j : = 1 to n do

    if ((j + i) mod 2 = 0) then

    write ('W':2)

    else

    write ('B':2) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача AДоска Задается N. Нужно вывести цвет каждой клетки доски N x N, если известно, что они покрашены в шахматном порядке и клетка (1, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Задача C. Делители Дано целое число N. Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < = N < = 10^12) Формат выходных данных Выведите ответ к задаче
Ответы (1)
Задача D Нечет Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B. Формат входных данных Первая строка входного файла содержит два целых числа A и B (1 < = A, B < = 10^9). Формат выходных данных Выведите ответ к задаче.
Ответы (1)
Вам дана строка S. Надо определить, сколько в ней цифр Формат входных данных Единственная строка входного файла содержит строку S, которая может состоять из букв английского алфавита и цифр.
Ответы (2)