Задать вопрос
2 февраля, 11:09

Арбуз диаметром Д1 см стоит на рынке С1 руб за кг, а арбуз диаметром Д2 см стоит С2 руб за кг. Толщина корки арбуза Т мм. Составить программу, сообщающую, какой арбуз выгоднее купить. Плотность мякоти и корки считать равными.

+1
Ответы (2)
  1. 2 февраля, 14:19
    0
    (Д1 - (С1+Т1)) - (Д2 - (С2 + Т2)). Если > 0, то выгоднее купить первый арбуз

    Если < 0, то выгоднее купить второй арбуз
  2. 2 февраля, 14:53
    0
    Var

    d1, d2, t, c1, c2, s1, s2: real;

    begin

    write ('Диаметр 1-го арбуза (см) : ') ;

    readln (d1) ;

    write ('Цена за кг 1-го арбуза: ') ;

    readln (c1) ;

    write ('Диаметр 2-го арбуза (см) : ') ;

    readln (d2) ;

    write ('Цена за кг 2-го арбуза: ') ;

    readln (c2) ;

    write ('Толщина корки (мм) : ') ;

    readln (t) ;

    t:=t/10;

    s1:=c1*power (d1/2,3) / (power ((d1/2-t),3)) ; / / стоимость ед. мякоти 1

    s2:=c2*power (d2/2,3) / (power ((d2/2-t),3)) ; / / стоимость ед. мякоти 2

    if s1
    else writeln ('Покупаем второй') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Арбуз диаметром Д1 см стоит на рынке С1 руб за кг, а арбуз диаметром Д2 см стоит С2 руб за кг. Толщина корки арбуза Т мм. Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Паскаль! 1. Напишите программу, запрашивающую у пользователя два момента времени (количество часов, минут и секунд) и сообщающую число секунд, прошедшее между этими двумя моментами. 2. Ввести два числа.
Ответы (1)
Индивидуальное зачетное задание Напишите программу, запрашивающую у пользователя время и сообщающую угол поворота минутной и часовой стрелки в градусах и радианах (помните, что тригонометрические функции в Паскале работают с радианами)
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Автомат по продаже билетов принимает купюры достоинством 10 руб. и 50 руб. в 100 руб. но требует оплаты без сдачи. Билет стоит 130 руб. Какое минимальное количество билетов может купить может купить пассажир потратив 10 банкнот?
Ответы (1)