Задать вопрос
13 января, 13:40

Напишите программу формирования и вывода массива размером 6*3, каждые три последовательных элемента в строке которого составлены по следующему правилу:

1-й - равен квадрату суммы текущих индексов, увеличенному на 5

2-й - равен целой части квадратного корня из предыдущего элемента;

3-й - равен целой части частного от деления двух предыдущих элемента.

+4
Ответы (1)
  1. 13 января, 16:51
    0
    1)

    var a:array[1 ... 100,1 ... 100] of Real; i, j:integer; n, m:integer; begin write ('Rows=') ; readln (n) ; write ('Cols=') ; readln (m) ; for i:=1 to n do begin for j:=1 to 2 do begin write ('[', i,',', j,']=') ; readln (a[i, j]) ; end; For j:=3 to m do a[i, j]:=a[i, j-1]+a[i, j-2]; end; For i:=1 to n do begin for j : = 1 to m do write (a[i, j]:8:3) ; writeln; end; readln; end.

    2)

    var a:array[1 ... 6,1 ... 3] of Real; i, j:integer; begin Randomize; for i:=1 to 6 do begin j:=1; a[i, 1]:=sqr (i+j) ; a[i, 2]:=random (18) - 9; a[i, 3]:=a[i, 1]/2+a[i, 2]/2; For j:=1 to 3 do write (a[i, j]:8:1) ; writeln; end; readln; end.

    Но это на языке паскаль я фиг знает какой тебе нада тут два варианта
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу формирования и вывода массива размером 6*3, каждые три последовательных элемента в строке которого составлены по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу формирования и вывода массива размером 6 х3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й равен квадрату суммы индексов следующего элемента.
Ответы (1)
1 Задание: сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса;
Ответы (1)
Дан массив на 9 элементов. Первый элемент равен квадрату текущего индекса, увеличенному на 5. Второй элемент равен целой части квадратного корня из предыдущего элемента. Третий элемент равен сумме двух предыдущих элементов
Ответы (1)
1. Сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен случайному трехзначному числу; 2-й равен текущему индексу, увеличенному в 10 раз;
Ответы (2)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)