Задать вопрос
27 февраля, 16:02

Дан массив на 9 элементов. Первый элемент равен квадрату текущего индекса, увеличенному на 5. Второй элемент равен целой части квадратного корня из предыдущего элемента. Третий элемент равен сумме двух предыдущих элементов

+1
Ответы (1)
  1. 27 февраля, 17:42
    0
    Program n1;

    const n=9;

    var a: array[1 ... n] of integer;

    var i:integer;

    begin

    i:=1;

    while i<9 do

    begin

    a[i]:=i*i+5;

    a[i+1]:=trunc (sqrt (a[i])) ;

    a[i+2]:=a[i]+a[i+1];

    i:=i+3;

    end;

    for i:=1 to n do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив на 9 элементов. Первый элемент равен квадрату текущего индекса, увеличенному на 5. Второй элемент равен целой части квадратного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1 Задание: сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса;
Ответы (1)
Напишите программу формирования и вывода массива размером 6*3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й - равен квадрату суммы текущих индексов, увеличенному на 5 2-й - равен целой части
Ответы (1)
Известен первый элемент массива А: A[1]=6. Создать массив, каждый элемент которого равен квадрату предыдущего индекса. Вывести полученный массив на экран, расположив каждый элемент отдельной строке
Ответы (1)
Сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен удвоенному числу, введенному с клавиатуры; 2-й равен квадрату предыдущего индекса;
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)