Задать вопрос
3 апреля, 15:27

Напишите программу формирования и вывода массива размером 6 х3, каждые три последовательных элемента в строке которого составлены по следующему правилу:

1-й равен квадрату суммы индексов следующего элемента.

2-й равен удвоенной сумме текущих индексов

3-й равен разности двух предыдущих элементов.

Паскаль

+1
Ответы (1)
  1. 3 апреля, 16:09
    0
    Const

    N = 6;

    M = 3;

    Var

    A:array[1 ... N, 1 ... M] of integer;

    i:integer;

    Begin

    For i: = 1 to N do

    Begin

    A[i, 1]:=sqr (i+2) ;

    A[i, 2]:=2*i+4;

    A[i, 3]:=A[i, 2]-A[i, 1];

    WriteLn (A[i, 1]:3,' ', A[i, 2]:3,' ', A[i, 3]:3) ;

    End;

    End.

    Результат работы программы:

    9 6 - 3

    16 8 - 8

    25 10 - 15

    36 12 - 24

    49 14 - 35

    64 16 - 48
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу формирования и вывода массива размером 6 х3, каждые три последовательных элемента в строке которого составлены по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу формирования и вывода массива размером 6*3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й - равен квадрату суммы текущих индексов, увеличенному на 5 2-й - равен целой части
Ответы (1)
1 Задание: сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса;
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен случайному трехзначному числу; 2-й равен текущему индексу, увеличенному в 10 раз;
Ответы (2)