Задать вопрос
19 января, 01:24

Создать

массив у, элементы которого вычисляют по формуле уk = ln (k) -

3, где k = 1, 2, ..., 10. Построить массив g, состоящий из отрицательных

элементов массива у. Найти в массиве отрицательные элементы и заменить их

значение на модуль числа. Определить их количество

+2
Ответы (1)
  1. 19 января, 03:16
    0
    Var

    y:array[1 ... 10]of real;

    g:array of real;

    i, j, n:integer;

    begin

    for i:=1 to 10 do

    begin

    y[i]:=ln ((random (500) + 1) / 10) - 3;

    if y[i]<0 then n:=n+1;

    write (y[i],' ') ;

    end;

    writeln;

    writeln ('Количество отрицательных: ', n) ;

    writeln ('Измененный массив: ') ;

    setlength (g, n) ;

    for i:=1 to 10 do

    begin

    if y[i]<0 then

    begin

    g[j]:=y[i];

    y[i]:=-y[i];

    j:=j+1

    end;

    write (y[i],' ')

    end;

    writeln;

    writeln ('Массив g:') ;

    for i:=0 to n-1 do write (g[i],' ')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать массив у, элементы которого вычисляют по формуле уk = ln (k) - 3, где k = 1, 2, ..., 10. Построить массив g, состоящий из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)