Задать вопрос
31 марта, 07:25

Даны числа x, y и z. Составьте программу, которая возводит в квадрат те из них, которые не отрицательные

+5
Ответы (1)
  1. 31 марта, 08:58
    0
    Var

    x, y, z : real;

    begin

    read (x, y, z) ;

    if (x > 0) then x : = sqr (x) ;

    if (y > 0) then y : = sqr (y) ;

    if (z > 0) then z : = sqr (z) ;

    write (x, ' ', y, ' ', z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны числа x, y и z. Составьте программу, которая возводит в квадрат те из них, которые не отрицательные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано целое число c. Напишите программу, которая возводит в квадрат частное от целочисленного деления числа c на 5 и выводит на экран монитора результат. 2. Дано целое число c.
Ответы (1)
Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат 2) четные числа заменяет на 2, а от нечетных - отнимает 5 3) числа,
Ответы (1)
Составьте программу, которая из трех введенных с клавиатуры чисел возводит в квадрат положительные, а отрицательные оставляет без изменения.
Ответы (1)
1 - возведи в квадрат 2 - вычти1 Первая из них возводит число на экране во вторую степень, вторая вычитает на числа 1. Составьте алгоритм получения из числа 2 числа 13, содержащии не более 5 каманд. В ответе запишите только номер команд.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)