Задать вопрос
9 ноября, 20:34

Написать в Паскаль программу для решения следующей задачи.

Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку, добавляя после каждого символа символ '0'.

+1
Ответы (1)
  1. 9 ноября, 23:11
    0
    Function add (s:string) : string;

    var i, d:integer;

    begin

    d:=length (s) ;

    i:=1;

    while i<=d*2 do begin

    insert ('0', s, i+1) ;

    inc (i, 2) ;

    end;

    add:=s;

    end;

    var s:string;

    begin

    readln (s) ;

    writeln (add (s)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать в Паскаль программу для решения следующей задачи. Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать в паскаль. Вводится две строки. Написать пользовательскую функцию которая возвращает строку 'da' если количество символов в этих строках одинаково и возвращает 'net' если неодинаково.
Ответы (1)
Python Middle: 1. Напиcать функцию, которая возвращает частное двух чисел, полученных в качестве аргументов. 2. Напиcать функцию, которая возвращает минимальное из двух чисел, полученных в качестве аргументов. 3.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Установите взаимно-однозначное соответствие между функциями и их действием: 1) Возвращает значение, следующее за х а) chr (x) 2) Возвращает значение, предшествующее х б) pred (x) 3) Возвращает символ с кодом х, где х - целое число от 0 до 255 в)
Ответы (1)
Серёжа мечтает о том, что бы каждый второй символ был #. Он пытался написать программу, которая вводила строку, а потом выводила вместе каждого второго символа "#", но у него не получилось этого сделать. Помогите ему осуществить свою мечту.
Ответы (1)