Задать вопрос
13 июля, 21:46

Найти все двузначные числа содержащие цифру n в паскале

+5
Ответы (1)
  1. 13 июля, 22:27
    0
    Var i, j, n: integer;

    m: string;

    begin

    readln (n) ;

    for i : = 10 to 99 do

    begin

    m : = inttostr (i) ;

    for j : = 1 to length (m) do

    if (m[j] = inttostr (n)) then writeln (i) ;

    end;

    end.

    Вот так=)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все двузначные числа содержащие цифру n в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти все двузначные числа, которые делятся на n и содержат в себе цифру n P. S. написать программу в Паскале через цикл while
Ответы (1)
1. Дана цифра А. Найти все двузначные числа в которых встречается эта цифра. 2. Вывести на экран все двузначные числа сумма цифр которых делится на 5. 3. Найти среднее арифметическое чисел в промежутке от А до В.
Ответы (1)
Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось 237. Найти число x. Решить на Паскале
Ответы (1)
Решить в Паскале с помощью операторов while и repeat 1) Вывести на экран все четные числа из диапазона от A до В, кратные трём (А
Ответы (1)
Аня написала все целые числа в промежутке (65; 101) в восьмеричной системе счисления. Ваня стер все числа, содержащие цифру 7. Найдите сумму оставшихся чисел в восьмеричной системе счисления и переведите в четверичную систему счисления.
Ответы (1)