Задать вопрос
30 апреля, 07:17

Найти все двузначные числа, которые делятся на n и содержат в себе цифру n

P. S. написать программу в Паскале через цикл while

+1
Ответы (1)
  1. 30 апреля, 09:02
    0
    Var

    A, N, C:byte;

    B:boolean;

    Begin

    B:=false;

    Write ('N = ') ; ReadLn (N) ;

    A:=10;

    While A<100 do

    Begin

    if A mod N = 0 then

    Begin

    C:=A;

    While C0 do

    Begin

    if C mod 10 = N then B:=true;

    C:=C div 10

    End;

    if B then Write (A,' ') ;

    B:=false

    End;

    A:=A+1

    End

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все двузначные числа, которые делятся на n и содержат в себе цифру n P. S. написать программу в Паскале через цикл while ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы