Задать вопрос
17 августа, 11:25

даны 2 точки а (х1; у1) и b (х2; у2) определить какая из точек находиться ближе к началу координат. записать на языке паскаль

+1
Ответы (1)
  1. 17 августа, 14:06
    0
    Program gt;

    var x1, x2, y1, y2:real;

    begin

    readln (x1, y1, x2, y2) ;

    if (x1*x1+y1*y1) < (x2*x2+y2*y2) then writeln ('первая точка ближе') else

    if (x1*x1+y1*y1) > (x2*x2+y2*y2) then writeln ('вторая точка ближе') else writeln ('одинаково расположены') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «даны 2 точки а (х1; у1) и b (х2; у2) определить какая из точек находиться ближе к началу координат. записать на языке паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! На плоскости заданы три точки своими координатами. Определить расстояние от точек до начала координат и напечатать, какая из точек расположена ближе к началу координат. (с повтором)
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.
Ответы (1)
Составьте программу, позволяющую определить, какая из двух точек (х1, y1), (х2, y2) ближе к началу координат. Это паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)