Задать вопрос
22 ноября, 11:52

Массив состоит из 20 целых чисел от 0 до 10. Найти в массиве те элементы, значение которых меньше среднего арифметического, взятого от всех элементов массива и вывести их в виде ответа. Паскаль.

+4
Ответы (1)
  1. 22 ноября, 12:51
    0
    Исходный код на языке программирования Pascal

    const N = 10;

    var

    a: array[1 ... N] of integer;

    i: byte;

    avrg: real;

    sum: integer;

    begin

    randomize;

    for i:=1 to N do a[i]:=random (50) + 1;

    sum : = 0;

    for i:=1 to N do sum : = sum + a[i];

    avrg : = sum/N;

    / / весь массив

    for i:=1 to N do write (a[i]:3) ;

    writeln;

    writeln ('Среднее арифм.: ', avrg:4:2) ;

    / / больше avrg

    for i:=1 to N do if a[i]
    writeln;

    end.

    Пример (ы) выполнения программы на языке Pascal

    13 23 45 2 9 28 47 30 18 12

    Среднее арифм.: 22.70

    13 2 9 18 12
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Массив состоит из 20 целых чисел от 0 до 10. Найти в массиве те элементы, значение которых меньше среднего арифметического, взятого от всех ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)