Задать вопрос
1 июля, 04:15

Написать программу для решения задачи: Сравнить первую и последнюю цифру натурального четырёхзначного числа n. На экране должен появиться запрос на ввод числа и результат решения задачи, например 1) вводится число 1475, выводится "первая цифра меньше последней: 12". 3) вводится число 7457, выводится "первая цифра равна последней: 7=7"

+3
Ответы (1)
  1. 1 июля, 06:28
    0
    var n:integer;

    begin

    write ('Введите 4-х значное число: ') ;

    readln (n) ;

    if n div 1000 = n mod 10 then write ('Первая цифра равна последней: ', n div 1000,'=', n mod 10)

    else if n div 1000 > n mod 10 then write ('Первая цифра больше последней: ', n div 1000,'>', n mod 10)

    else write ('Первая цифра меньше последней: ', n div 1000,'<', n mod 10)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для решения задачи: Сравнить первую и последнюю цифру натурального четырёхзначного числа n. На экране должен появиться ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Нужно как из четырёхзначного числа сравнить первую и последнюю цифру и две средних вопрос в том что как их вытащить из этого числа? первую и последнюю я понял как Console. WriteLine ("Введите четырёхзначное число") ; m = int. Parse (Console.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу, начинающуюся с команды Ввод, заканчивающуюся командой Вывод. Программе на ввод дается h1, m1, s1 и h2, m2, s2 Это часы минуты и секунды начала отсчета и конца отсчета времени.
Ответы (2)