Задать вопрос
4 ноября, 19:50

В массиве из 12 элементов, заданных по формуле F[i]=i^2-5i-14

Найдите сумму положительных значений

+3
Ответы (1)
  1. 4 ноября, 20:43
    0
    1) Заполним массив по формуле из условия

    2) Пройдёмся по массиву и посчитаем сумму положительных значений.

    Всё можно сделать в одном цикле.

    Код

    var

    f: array[1 ... 12] of integer;

    i, ans: integer;

    begin

    ans : = 0;

    for i : = 1 to 12 do

    begin

    f[i] : = i * i - 5 * i - 14;

    if f[i] > 0 then ans : = ans + f[i];

    end;

    writeln (ans) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве из 12 элементов, заданных по формуле F[i]=i^2-5i-14 Найдите сумму положительных значений ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль, помогите! В числовом массиве из 10 элементов, заданных случайным образом от - 100 до 500. Найти: 1) сумму положительных элементов, стоящих на чётных местах; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах;
Ответы (1)
Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9. Сформировать новый массив из значений элементов, стоящих на четных местах. Подсчитать количество отрицательных и положительных значений элементов в новом массиве.
Ответы (2)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)