Задать вопрос
16 февраля, 09:03

Объявить целочисленный массив. Ввести значения элементов массива с клавиатуры. Заменить неотрицательные элементы массива их кубом, другие удвоить. Вывести полученный массив на экран

+2
Ответы (1)
  1. 16 февраля, 10:32
    0
    Сначала нужно ввести количество элементов массива, потом сам массив:

    #include

    using namespace std;

    int main ()

    {

    int n;

    cin >> n;

    int a[n];

    for (int i = 0; i < n; + + i)

    {

    cin >> a[i];

    if (a[i] > = 0)

    a[i] * = a[i]*a[i];

    else

    a[i] * = 2;

    cout << a[i] << ' ';

    }

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Объявить целочисленный массив. Ввести значения элементов массива с клавиатуры. Заменить неотрицательные элементы массива их кубом, другие ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)