Задать вопрос
21 июля, 01:32

Напишите программу в pascal

Задаются границы диапазона

найти сумму тех чисел которые четные

+4
Ответы (1)
  1. 21 июля, 05:17
    0
    var a, b, i, z, x:integer;

    q:array [1 ... 20] of integer;

    begin

    write ('Верхняя граница=') ; readln (a) ;

    write ('Нижняя граница=') ; readln (b) ; x:=a-b; randomize;

    for i:=1 to 20 do

    begin

    q[i]:=random (x) + b;

    write (q[i],' ') ;

    if (q[i]mod 2=0) then z:=z+q[i];

    end;

    writeln;

    write ('Сумма четных чисел=', z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в pascal Задаются границы диапазона найти сумму тех чисел которые четные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа a и b, и выводит сумму квадратов натуральных чисел в диапазоне от a до b. Входные данные Входная строк содержит два натуральных числа - границы диапазона a и b.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)