Задать вопрос
19 июля, 20:28

Как найти числа армстронга от нуля до заданного числа на С++

(желательно используя простые функции из обычных библиотек типа iostream, stdio. h, math. h) ?

+5
Ответы (1)
  1. 19 июля, 21:19
    0
    Задачу проще всего решить, уже имея набор этих чисел, а их не так много и их можно найти в интернете)

    #include

    #include

    using namespace std;

    int main () {

    vector armstrong = {1, 2, 3, 4, 5, 6, 7, 8, 9, 153, 370, 371, 407, 1634, 8208, 9474, 54748, 92727, 93084, 548834, 1741725, 4210818, 9800817, 9926315, 24678050, 24678051, 88593477, 146511208, 472335975, 534494836, 912985153, 4679307774};

    long long int n;

    int l = armstrong. size () ;

    cin >> n;

    for (int i = 0; i < l && armstrong[i] < = n; + + i)

    cout << armstrong[i] << '/n';

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как найти числа армстронга от нуля до заданного числа на С++ (желательно используя простые функции из обычных библиотек типа iostream, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Мальчик коля хорошо считал, поэтому для составления пароля он использовал числа армстронга. (Натуральное десятичное N - значное число называется числом армстронга, если сумма его цифр возведённых в степень N, равна самому числу.
Ответы (1)
Пользователь работал с файломC:/Doc/Class/9v/Lesson/math. doc. Затем он поднялся на один уровень вверх, создал каталог Topic, в нём создал ещё один каталог Algebra ипереместил в него файл math. doc.
Ответы (2)
Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - количество цифр в числе) равна самому числу. Например, 153 = 1 3 + 5 3 + 3 3.
Ответы (1)
Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в N-ю степень, где N - количество цифр в числе, равна самому числу. Напримерт153=1^3 5^3 3^3. Найдитетвсе трехзначныеии четырехзначныеичисла Армстронга
Ответы (1)
В городе 3 района, в районе х библиотек для детей, у библиотек для взрослых. Сколько библиотек в городе и сколько в районе
Ответы (1)