Задать вопрос
9 апреля, 01:32

Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в N-ю степень, где N - количество цифр в числе, равна самому числу. Напримерт153=1^3 5^3 3^3. Найдитетвсе трехзначныеии четырехзначныеичисла Армстронга

+5
Ответы (1)
  1. 9 апреля, 05:29
    0
    Var a, b, c, d, a2:integer;

    begin

    for a:=100 to 9999 do begin

    d:=0;

    a2:=a;

    while (a2 0) do begin

    b: = a2 mod 10;

    a2: = a2 div 10;

    if a<1000 then c: = (b*b*b)

    else c: = (b*b*b*b) ;

    d: = d+c;

    end;

    if (a = d) then writeln ('число армстронга = = > ', a) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в N-ю степень, где N - количество цифр в числе, равна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - количество цифр в числе) равна самому числу. Например, 153 = 1 3 + 5 3 + 3 3.
Ответы (1)
Мальчик коля хорошо считал, поэтому для составления пароля он использовал числа армстронга. (Натуральное десятичное N - значное число называется числом армстронга, если сумма его цифр возведённых в степень N, равна самому числу.
Ответы (1)
Написать в VBA, используя подпрограмму: Натуральное число, в записи которого n цифр, называется числом Амстронга, если сумма его цифр, возведенных в степень n равна самому числу. Найти все эти числа от 1 до k.
Ответы (1)
в Паскале 1. Среди четырёхзначных чисел выбрать те, у которых все четыре цифры различны. 2. Дано шестизначное число n. Определить сколько раз в нём повторяется минимальная цифра. 3.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)