Задать вопрос
17 мая, 13:01

Сформировать целочисленный массив из n элементов. Значение элементов вводится с клавиатуры. Найти произведение элементов с черными номерами. Pascal

+3
Ответы (2)
  1. 17 мая, 13:55
    0
    program mas;

    cоnst n=5;

    var

    a:array[1 ... n] of integer;

    i, t:integer;

    begin

    writeln ('Введите ', n,' елементов массива') ;

    for i:=1 to n do readln (m{i}) ;

    t:=1;

    for i:=2 to n do t:=t*m{i};

    write ('вывод массива: ') ;

    for i:=1 to n do write (m{i},' ') ;

    writeln ('Результат произведения элементов массива: ', t) ;

    readln;

    end.
  2. 17 мая, 16:41
    0
    Var a:array[1 ... 1000] of integer;

    n, i, p:integer;

    begin

    write ('Введите количество элементов массива (n<1000) : ') ;

    readln (n) ;

    for i:=1 to n do readln (a[i]) ;

    write ('Массив: ') ;

    for i:=1 to n do write (a[i],' ') ;

    writeln;

    p:=1;

    for i:=2 to n do

    if i mod 2 = 0 then p:=p*a[i];

    writeln ('Произведение элементов с чётными номерами равно ', p) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать целочисленный массив из n элементов. Значение элементов вводится с клавиатуры. Найти произведение элементов с черными ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)