Задать вопрос
25 июня, 20:14

Сформировать одномерный массив:

1 вывести элементы массива в обратном порядке.

2 поменять местами первый и последний элементы.

3 найти среднее арифметическое элементов массива.

+5
Ответы (1)
  1. 25 июня, 21:29
    0
    const n=15;

    var a:array [1 ... n] of integer;

    i, s, v:integer;

    begin

    writeln ('Массив: ') ;

    for i: = 1 to n do

    begin

    a[i]: = Random (90) + 10;

    s:=s+a[i];

    write (a[i],' ')

    end;

    writeln;

    writeln ('Элементы массива в обратном порядке: ') ;

    for i: = n downto 1 do write (a[i],' ') ;

    writeln;

    v:=a[1];

    a[1]:=a[n];

    a[n]:=v;

    writeln ('Поменять местами первый и последний элементы: ') ;

    for i: = 1 to n do write (a[i],' ') ;

    writeln;

    writeln ('Среднее арифметическое всех элементов массива равно ', s/n:0:3)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать одномерный массив: 1 вывести элементы массива в обратном порядке. 2 поменять местами первый и последний элементы. 3 найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Организовать ввод чисел в массив E состоящий из 7 элементов ввод с клавиатуры сформировать новый массив К состоящий из элементов которые равны квадратам элементов массива Е вывести элементы массива Е найти и вывести номер минимального элемента
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)