Задать вопрос
26 июля, 21:50

Дано целое число определить равна ли сумма факториалов цифр данного числа самому числу. паскаль, процедуры.

+5
Ответы (1)
  1. 27 июля, 01:05
    0
    program DigFact;

    var x: Integer;

    function factorial (x: integer) : integer; var i: integer; y: integer; begin y:=x; for i:=1 to x-1 do begin dec (y) ; x:=x*y; end; factorial:=x; end;

    function factorialSum (x: integer) : integer; var y: integer; begin factorialSum:=0; repeat y:=x mod 10; x:=x div 10; factorialSum:=factorialSum+factorial (y) ; until x = 0; end;

    begin write ('x = ') ; readln (x) ; if factorialSum (x) = x then writeln ('True') else writeln ('False') ; readln () ; end. Интересное задание, поломал голову немного.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число определить равна ли сумма факториалов цифр данного числа самому числу. паскаль, процедуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Написать программу из 2 частей. В основной программе посчитать сумму факториалов всех нечетных чисел с 1 до 9. Подсчет факториалов реализовать в функции
Ответы (2)
Пример 6. Составим функцию, которая вычисляет сумму цифр числа. Будем рассуждать так: сумма цифр числа n равна значению последней цифры плюс сумма цифр числа div (n, 10).
Ответы (1)
Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - количество цифр в числе) равна самому числу. Например, 153 = 1 3 + 5 3 + 3 3.
Ответы (1)