Задать вопрос
16 августа, 11:45

Написать программу из 2 частей. В основной программе посчитать сумму факториалов всех нечетных чисел с 1 до 9. Подсчет факториалов реализовать в функции

+3
Ответы (2)
  1. 16 августа, 13:47
    0
    Program gt;

    var i, s, l:integer;

    function IOI (a:integer) : integer;

    begin

    if (a mod 2=1) then IOI:=1 else IOI:=0;

    end;

    begin

    s:=1;

    l:=1;

    for i:=2 to 9 do

    begin

    if (IOI (i) = 1) then begin

    l:=l*i * (i-1) ;

    s:=s+l;

    end;

    end;

    writeln (s) ;

    end.
  2. 16 августа, 14:16
    0
    На Visual Basic с массивом

    Sub Program

    Dim A (10) As Integer, i As Integer, S As Long

    S = 0

    For i = 1 To 9 Step 2

    A (i) = i

    S = S + Fact (A (i))

    Next i

    Text1. Text = S

    End Sub

    Function Fact (n)

    Dim i As Integer

    Fact = 1

    For i = 1 To n

    Fact = Fact * i

    Next i

    End Function

    Почему во всех институтах изучают Pascal,

    если программы на Basic короче и быстрее работают?
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу из 2 частей. В основной программе посчитать сумму факториалов всех нечетных чисел с 1 до 9. Подсчет факториалов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Написать программу вычисления суммы факториалов всех нечетных чисел от 1 до 9. С помощью функции
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Написать в VBA через подпрограмму: Написать программу вычисления суммы факториалов всех нечетных чисел от 1 до 9.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)