Задать вопрос
9 августа, 01:16

Найти все натуральные трехзначные числа, сумма цифр которых кратна заданному натуральному числу В и само число также делится на В.

+3
Ответы (1)
  1. 9 августа, 02:13
    0
    C++

    #include

    using namespace std;

    int main () {

    int b;

    cin >> b;

    for (int i=100; i<1000; ++i) {

    if ((i/100 + (i%100) / 10+i%10) %b==0&&i%b==0) {

    cout << i << " ";

    }

    }

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все натуральные трехзначные числа, сумма цифр которых кратна заданному натуральному числу В и само число также делится на В. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
А. Составьте подпрограмму-функцию, которая по заданному натуральному числу n вычислит сумму его цифр. б. Составьте алгоритм, подсчитывающий количество n-значных натуральных чисел, у каждого из которых сумма цифр равна заданному натуральному числу k.
Ответы (1)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Дано двузначное числи. Определит. А) кратна ли трем сумма его цифр Б) кратна ли сумма его цифр числу a.
Ответы (1)
Составить программу в Pascal: Найти все трехзначные числа, обладающие следующими свойствами: - сумма цифр числа А делится на 4; - сумма цифр числа А+2 также делится на 4
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)