Задать вопрос
16 мая, 13:53

Написать на СИ. Составить программу, формирующую одномерный массив, со-

стоящий из N целых элементов. Вычислить сумму положительных элемен-

тов массива. Определить количество элементов, имеющих четные поряд-

ковые номера и являющиеся нечетными числами. Упорядочить элементы

массива по возрастанию.

+2
Ответы (1)
  1. 16 мая, 16:15
    0
    Важное замечание: Программа будет работать только при компиляции компилятором, поддерживающим стандарт C99.

    #include

    #include

    int compare (const int * A, const int * B) ; / / компаратор для qsort

    int main ()

    {

    int N;

    printf ("Введите размер массива: ") ;

    scanf ("%d", &N) ;

    int

    arr[N],

    sum = 0,

    number = 0;

    for (int i = 0; i < N; i++)

    scanf ("%d", &arr[i]) ;

    for (int i = 0; i < N; i++)

    printf ("%d ", arr[i]) ;

    printf ("/n") ;

    for (int i = 0; i < N; i++)

    {

    if (arr[i])

    sum + = arr[i];

    if ((arr[i] % 3 = = 0) && (i % 2 = = 0))

    number + = 1;

    }

    qsort (arr, N, sizeof (int), compare) ;

    for (int i = 0; i < N; i++)

    printf ("%d ", arr[i]) ;

    printf ("/nСумма положительных элементов = %d/n/

    количество элементов, имеющих четные порядковые номера и являющиеся нечетными числами = %d", sum, number) ;

    return 0;

    }

    int compare (const int * A, const int * B)

    {

    return * A - * B;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать на СИ. Составить программу, формирующую одномерный массив, со- стоящий из N целых элементов. Вычислить сумму положительных элемен- ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Free pascal! Дан массив определенной длины. Проинициализировать массив и найти количество элементов массива, имеющих четные порядковые номера, но являющиеся нечетными числами.
Ответы (1)