Задать вопрос
27 июля, 09:56

Free pascal! Дан массив определенной длины. Проинициализировать массив и найти количество элементов массива, имеющих четные порядковые номера, но являющиеся нечетными числами.

+4
Ответы (1)
  1. 27 июля, 11:20
    0
    Uses Crt;

    Const N = 13;

    Var

    A:array[1 ... N] of integer;

    i, k:integer;

    Begin

    Randomize;

    ClrScr;

    k:=0;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    if (i mod 2 = 0) and (A[i] mod 2 0) then k:=k+1;

    End;

    WriteLn;

    Write ('k = ', k) ;

    ReadLn

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Free pascal! Дан массив определенной длины. Проинициализировать массив и найти количество элементов массива, имеющих четные порядковые ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
2. Дан массив из N элементов. Определить количество элементов, имеющих четные порядковые номера и являющихся нечетными числами.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)