Задать вопрос
31 мая, 15:52

С клавиатуры вводится последовательность чисел, оканчивающаяся нулём. Определить количество чисел, кратных 5, во введенной последовательности.

+3
Ответы (1)
  1. 31 мая, 16:08
    0
    var i, k, x:integer;

    begin

    i:=0;

    x:=1;

    while x0 do

    begin

    read (x) ;

    if (x mod 5=0) and (x0) then k:=k+1;

    end;

    writeln ('Количество чисел кратных 5 = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится последовательность чисел, оканчивающаяся нулём. Определить количество чисел, кратных 5, во введенной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем. Найти количество отрицательных чисел и сумму чисел кратных 4.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Определите сумму всех элементов последовательности, завершающейся числом 0. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Ответы (1)
С клавиатуры вводится последовательность чисел до тех пор пока не будет введено число 0. требуется найти произведение чисел из введенной последовательности кратных пяти
Ответы (1)