Задать вопрос
10 мая, 01:08

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем. Найти количество отрицательных чисел и сумму чисел кратных 4.

+4
Ответы (1)
  1. 10 мая, 05:02
    0
    Var

    x, s, count: longint;

    begin

    x : = 1;

    s : = 0;

    count : = 0;

    while x 0 do

    begin

    read (x) ;

    if x < 0 then

    inc (count) ;

    if x mod 4 = 0 then

    s : = s + x;

    end;

    writeln (count, ' ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем. Найти количество отрицательных чисел и сумму чисел кратных 4. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
С клавиатуры вводится последовательность чисел, оканчивающаяся нулём. Определить количество чисел, кратных 5, во введенной последовательности.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Определите сумму всех элементов последовательности, завершающейся числом 0. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Ответы (1)