Задать вопрос
20 марта, 08:41

Из n, введенных с клавиатуры чисел, найти сумму и кол-во отрицательных (паскаль)

+3
Ответы (1)
  1. 20 марта, 08:57
    0
    Var

    i, n, sum, k, a:Integer;

    begin

    Writeln ('Введмте кол-во чисел в последовательности') ;

    ReadLn (n) ;

    Writeln ('Введите числа') ;

    for i:=1 to n do

    begin

    Readln (a) ;

    if a<0 then

    begin

    sum:=sum+a;

    k:=k+1;

    end;

    end;

    WriteLn ('В данной последовательности ', k, ' отрицательный (ых) элемента (ов) ') ;

    WriteLn ('Их сумма = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Из n, введенных с клавиатуры чисел, найти сумму и кол-во отрицательных (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Составьте программу, которая: а) Определяет коды двух введённых с клавиатуры символов; б) Выполняет операцию сцепления трёх введённых с клавиатуры символов; на Pascal
Ответы (1)