Задать вопрос
12 июля, 21:49

Составьте программы:

1. Определить является ли число чётным

2. Найти первую цифру 3-х значного числа и определить делится ли она на 3

+1
Ответы (1)
  1. 13 июля, 01:16
    0
    1) var a:integer;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    if a mod 2=0 then writeln ('Число чётное')

    else writeln ('Число нечётное') ;

    end.

    2) var a, b:integer;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    b: = a div 100;

    if b>9 then writeln ('Ошибка') else begin

    writeln ('Первая цифра это') ;

    writeln (b) ;

    if b mod 3=0 then writeln ('Первая цифра числа делится на 3')

    else writeln ('Первая цифра числа не делится на 3') ; end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программы: 1. Определить является ли число чётным 2. Найти первую цифру 3-х значного числа и определить делится ли она на 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)
Программирование. Составить программы для решения задач: (калькулятор) 1. Дана площадь квадрата. Вычислить периметр этого квадрата 2. Дано натуральное число Х. Определить, является ли оно четным и делится ли это число на 3
Ответы (1)
Дано целое число. Определить, является оно четным или не четным
Ответы (1)
Ребят, помогите! написать программу: Является ли сумма цифр заданного 7-значного числа, стоящих в разрядах десятков тысяч, сотен и единиц (1 234 567) числом четным или кратным 7?
Ответы (1)