Задать вопрос
2 апреля, 16:24

Решить в Паскале

Определить содержит ли массив А[1 ... 20] случайное число Х, введеное с клавиатуры.

+2
Ответы (1)
  1. 2 апреля, 20:20
    0
    Program 1;

    Var a:array[1 ... 20] of integer;

    X, i, k: integer;

    Begin

    Writeln ('введите элементы массива') ;

    For i:1 to 20 do

    Readln (a[i]) ;

    Writeln ('введите х=') ;

    Readln (x) ;

    For i:=1 to 20 do

    If x=a[i]

    Then k:=k+1;

    If k>0

    Then writeln ('да, содержит')

    Else writeln ('нет, не содержит') ;

    END.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в Паскале Определить содержит ли массив А[1 ... 20] случайное число Х, введеное с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)