Задать вопрос
28 сентября, 19:51

Помогите решить

В массиве а1, а2, а3 ... а15 подсчитать количество элементов, больших среднего арифметического, и количество меньших и равных среднему арифметическому элементов массива.

+5
Ответы (1)
  1. 28 сентября, 20:56
    0
    Const

    maxn = 15;

    type

    myarr = array [1 ... maxn] of longint;

    var

    a: myarr;

    k1, k2, k3, sr, i: longint;

    begin

    for i : = 1 to 15 do begin

    read (a[i]) ;

    sr : = sr + a[i];

    end;

    sr : = sr div 15;

    for i : = 1 to 15 do begin

    if (a[i] > sr) then

    inc (k1) ;

    if (a[i] = sr) then

    inc (k2) ;

    if (a[i] < sr) then

    inc (k3) ;

    end;

    writeln ('Количество элементов, больших среднего арифметического, = ', k1) ;

    writeln ('Количество элементов, равного среднему арифметическому, = ', k2) ;

    writeln ('Количество элементов, меньших среднего арифметического, = ', k3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить В массиве а1, а2, а3 ... а15 подсчитать количество элементов, больших среднего арифметического, и количество меньших и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Для целочисленного массива из 20 элементов вычислить количество элементов равных среднему арифметическому элементу массива (диапазон значений: от - 10 до 15)
Ответы (1)