Задать вопрос
9 марта, 14:32

Для целочисленного массива из 20 элементов вычислить количество элементов равных среднему арифметическому элементу массива (диапазон значений: от - 10 до 15)

+3
Ответы (1)
  1. 9 марта, 14:42
    0
    Эта программа может выглядеть так:

    uses Crt;

    const n=20;

    type Mas=array [1 ... n] of integer;

    var A: Mas;

    i, Sum, Col, Sred: integer;

    begin

    ClrScr;

    Randomize;

    Sum:=0;

    for i:=1 to n do

    begin

    A[i]:=-10+random (26) ;

    Write (A[i]:4) ;

    Sum:=Sum+A[i];

    end;

    WriteLn;

    Sred:=Sum div n;

    WriteLn ('Srednee:', Sred:4) ;

    Col:=0;

    for i:=1 to n do

    if A[i]=Sred then Col:=Col+1;

    WriteLn ('Col=', Col) ;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для целочисленного массива из 20 элементов вычислить количество элементов равных среднему арифметическому элементу массива (диапазон ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить В массиве а1, а2, а3 ... а15 подсчитать количество элементов, больших среднего арифметического, и количество меньших и равных среднему арифметическому элементов массива.
Ответы (1)
С клавиатуры задается число N не превышающее 20, определяющее количество элементов одномерного целочисленного массива. Затем вручную заполняется сам массив из N элементов.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)