Задать вопрос
9 апреля, 18:35

С клавиатуры задается число N не превышающее 20, определяющее количество элементов одномерного целочисленного массива. Затем вручную заполняется сам массив из N элементов. Особым элементом этого массива назовём элемент, значение которого больше своего индекса (порядкового номера). Нумерация индексов начинается с 1. Найти сумму особых элементов массива.

Входные данные: натуральное число N и N целочисленных элементов массива.

Выходные данные: число - сумма особых элементов массива.

Написать исходный код паскаль

+5
Ответы (1)
  1. 9 апреля, 19:28
    0
    Var

    i, n, summ: integer;

    mas: array[1 ... 20] of integer;

    begin

    n : = 0;

    summ : = 0;

    while n < = 0 do

    begin

    writeln ('enter N (1-20) = ') ;

    read (n) ;

    end;

    for i : = 1 to n do

    begin

    read (mas[i]) ;

    if mas[i] > i then

    summ : = summ + mas[i]

    end;

    writeln ('sum = ', summ) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры задается число N не превышающее 20, определяющее количество элементов одномерного целочисленного массива. Затем вручную ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)