Задать вопрос
25 апреля, 03:09

Паскаль, написать программу: Организовать с клавиатуры ввод N произвольных целых чисел. Определить количество отрицательных и сумму положительных.

+4
Ответы (1)
  1. 25 апреля, 03:39
    0
    Var

    n, i, a, kotr, sumpol: longint;

    begin

    readln (n) ;

    kotr : = 0;

    sumpol : = 0;

    for i : = 1 to n do begin

    read (a) ;

    if (a < 0) then

    inc (kotr)

    else

    sumpol : = sumpol + a;

    end;

    writeln ('Количество отрицательных чисел = ', kotr) ;

    writeln ('Сумма положительных чисел = ', sumpol) ;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль, написать программу: Организовать с клавиатуры ввод N произвольных целых чисел. Определить количество отрицательных и сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
6. Составить алгоритм и написать программу вычисления суммы и среднего значения только отрицательных чисел из вводимых N произвольных (как положительных, так и отрицательных) целых чисел. N не больше 10
Ответы (1)