Задать вопрос
27 сентября, 18:52

Паскаль: Дано натуральное число n. Необходимо определить, есть ли в нём цифра 3.

+2
Ответы (1)
  1. 27 сентября, 22:35
    0
    Program three;

    var n, k, i:integer;

    begin

    randomize;

    n:=random (32768) ;

    k:=n;

    repeat

    i:=n mod 10;

    n:=n div 10

    until (n:=0) or (i:=3) ;

    if i=3 then

    write ('Число', k ', содержит цифру 3')

    else

    write ('Число', k ', не содержит цифру 3')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль: Дано натуральное число n. Необходимо определить, есть ли в нём цифра 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Дано натуральное число. Определить: 1) Определить количество повторений заданной цифры в нем 2) Сколько раз в нем встречается цифра, равная последней 3) Количество четных цифр в нем. желательно в Basic. но можно и паскаль
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)