Задать вопрос
27 сентября, 21:20

написать функцию, сравнивающую две даты. функция должна возвращать (-1) если первая дата меньше второй, 0 - если первая и вторая даты одинаковы и 1 - если первая дата больше второй. паскаль. тема записи

+2
Ответы (1)
  1. 27 сентября, 22:17
    0
    Type date = record day: 1 ... 31; month: 1 ... 12; year: integer; end; var a: date : = (day: 8; month: 7; year: 2012) ; b: date : = (day: 6; month: 7; year: 2012) ; c:integer;

    procedure OutDate (d: date) ; begin with d do writeln (day, '.', month, '.', year) ; end; begin if a. year > b. year then c:=1 else c:=-1; if a. year = b. year then if a. month > b. month then c:=1 else c:=-1; if a. year = b. year then if a. month = b. month then if a. day > b. day then c:=1 else c:=-1; if a. year = b. year then if a. month = b. month then if a. day = b. day then c:=0; OutDate (a) ; OutDate (b) ; writeln ('otwet:', c) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать функцию, сравнивающую две даты. функция должна возвращать (-1) если первая дата меньше второй, 0 - если первая и вторая даты ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Нужно написать функцию bsearch, которая принимает на вход отсортированный по убыванию массив целых чисел и целое число X. В качестве результата функция должна возвращать индекс первого элемента массива, строго меньшего X.
Ответы (1)
На ленте расположены два массива разной длины. Каретка обозревает правый крайний элемент одного из них. Составьте программу для машины Поста, сравнивающую длины массивов и стирающую больший из них
Ответы (1)
В базе данных с атрибутами Имя файла, Размер, Дата изменения имеется запись со значениями Имя файла = "PR1. TXT", Размер = 156 Кb, Дата изменения = 25.06.06. Эта запись удовлетворяет условиям запросов: 1) (Имя файла / = "PR1.
Ответы (1)